Back to overview
Degraded
Degraded Performance — Document Cover Page Generation
Mar 03, 2026 at 03:57pm UTC
Affected services
Document Workspace
API
Resolved
Mar 03, 2026 at 04:40pm UTC
We've deployed a fix, latency is back to normal.
We will keep monitoring system health to ensure stability.
Affected services
Created
Mar 03, 2026 at 03:57pm UTC
Status: Identified
Started: March 2, 2026 ~16:00 UTC
Summary
Document cover page generation is currently experiencing failures. Requests to create cover pages may time out or return errors.
What's affected
- Generating and downloading document cover pages (PDF export)
What's not affected
- Document uploading, viewing, and sharing
- All other API endpoints and platform functionality
Current status
We have identified the issue and a fix is being deployed. We will update this page once the issue is resolved.
Affected services